gio-qt/flake.nix
2024-04-09 14:05:59 +02:00

28 lines
552 B
Nix

{
description = "Gio wrapper for Qt6 applications";
inputs.nixpkgs.url = "nixpkgs/nixpkgs-unstable";
outputs = {
nixpkgs,
self,
...
}: let
systems = [
"x86_64-linux"
"aarch64-linux"
];
forAllSystems = f: nixpkgs.lib.genAttrs systems (system: f system);
in {
packages = forAllSystems (system: let
pkgs = nixpkgs.legacyPackages.${system};
gio-qt6-pkg = (pkgs.qt6Packages.callPackage ./nix/package.nix {});
in {
gio-qt6 = gio-qt6-pkg;
default = gio-qt6-pkg;
});
};
}