41 lines
1.1 KiB
Nix
41 lines
1.1 KiB
Nix
{
|
|
buildNpmPackage,
|
|
lib,
|
|
nodejs,
|
|
fetchgit,
|
|
}:
|
|
|
|
buildNpmPackage rec {
|
|
pname = "out-of-your-element";
|
|
version = "3.0.5";
|
|
|
|
src = fetchgit {
|
|
url = "https://gitdab.com/cadence/out-of-your-element";
|
|
rev = "v3.0-beta5";
|
|
hash = "sha256-3Y6s9pNKKeqF6s4I2Rd4TpxXPCwqizXeil/sTDVnpr0=";
|
|
};
|
|
|
|
npmDepsHash = "sha256-1STam+Sjy2MQcK5TmRacoxmgErd2sNqw0yIFX2M+iZk=";
|
|
dontNpmBuild = true;
|
|
|
|
postInstall = ''
|
|
# create wrapper
|
|
makeWrapper "${lib.getExe nodejs}" "$out/bin/ooye-setup" \
|
|
--add-flags "$out/lib/node_modules/out-of-your-element/scripts/setup.js"
|
|
|
|
makeWrapper "${lib.getExe nodejs}" "$out/bin/ooye-addbot" \
|
|
--add-flags "$out/lib/node_modules/out-of-your-element/addbot.js"
|
|
|
|
makeWrapper "${lib.getExe nodejs}" "$out/bin/ooye-start" \
|
|
--add-flags "$out/lib/node_modules/out-of-your-element/start.js"
|
|
'';
|
|
|
|
meta = {
|
|
description = "";
|
|
homepage = "https://gitdab.com/cadence/out-of-your-element";
|
|
license = lib.licenses.agpl3Only;
|
|
maintainers = with lib.maintainers; [ grimmauld ];
|
|
mainProgram = "out-of-your-element";
|
|
platforms = lib.platforms.all;
|
|
};
|
|
}
|