39 lines
1.2 KiB
Nix
39 lines
1.2 KiB
Nix
{ config, lib, ... }:
|
|
{
|
|
networking = {
|
|
nameservers = lib.mkForce [ "127.0.0.1" "::1" ];
|
|
dhcpcd.extraConfig = "nohook resolv.conf"; # dhcp
|
|
networkmanager.dns = "none"; # nm
|
|
resolvconf.useLocalResolver = true; # resoved
|
|
};
|
|
|
|
services.dnscrypt-proxy2 = {
|
|
enable = true;
|
|
settings = {
|
|
ipv6_servers = config.networking.enableIPv6;
|
|
ipv4_servers = true;
|
|
require_dnssec = true;
|
|
dnscrypt_servers = true;
|
|
doh_servers = true;
|
|
odoh_servers = false;
|
|
require_nolog = true;
|
|
require_nofilter = true;
|
|
|
|
sources.public-resolvers = {
|
|
urls = [
|
|
"https://raw.githubusercontent.com/DNSCrypt/dnscrypt-resolvers/master/v3/public-resolvers.md"
|
|
"https://download.dnscrypt.info/resolvers-list/v3/public-resolvers.md"
|
|
];
|
|
cache_file = "/var/lib/dnscrypt-proxy2/public-resolvers.md";
|
|
minisign_key = "RWQf6LRCGA9i53mlYecO4IzT51TGPpvWucNSCh1CBM0QTaLn73Y7GFO3";
|
|
};
|
|
|
|
# You can choose a specific set of servers from https://github.com/DNSCrypt/dnscrypt-resolvers/blob/master/v3/public-resolvers.md
|
|
# server_names = [ ... ];
|
|
};
|
|
};
|
|
|
|
systemd.services.dnscrypt-proxy2.serviceConfig = {
|
|
StateDirectory = "dnscrypt-proxy";
|
|
};
|
|
}
|