home-manager/tests/modules/programs/alacritty/example-settings.nix
Thiago Kenji Okada fcc4259cdb
treewide: stub tests (#6275)
* ranger: stub tests

* alacritty: stub tests

* broot: stub tests

* zsh: stub tests

* vim-vint: stub tests
2025-01-08 16:24:04 +01:00

31 lines
577 B
Nix

{ config, ... }:
{
config = {
programs.alacritty = {
enable = true;
package = config.lib.test.mkStubPackage { };
settings = {
window.dimensions = {
lines = 3;
columns = 200;
};
keyboard.bindings = [{
key = "K";
mods = "Control";
chars = "\\u000c";
}];
};
};
test.stubs = { alacritty = { }; };
nmt.script = ''
assertFileContent \
home-files/.config/alacritty/alacritty.toml \
${./example-settings-expected.toml}
'';
};
}