home-manager/tests/modules/programs/vim-vint/basic-configuration.nix
Thiago Kenji Okada fcc4259cdb
treewide: stub tests (#6275)
* ranger: stub tests

* alacritty: stub tests

* broot: stub tests

* zsh: stub tests

* vim-vint: stub tests
2025-01-08 16:24:04 +01:00

29 lines
648 B
Nix

{ ... }:
{
programs.vim-vint = {
enable = true;
settings = {
cmdargs = {
severity = "error";
color = true;
env = { neovim = true; };
};
policies = {
ProhibitEqualTildeOperator.enabled = false;
ProhibitUsingUndeclaredVariable.enabled = false;
ProhibitAbbreviationOption.enabled = false;
ProhibitImplicitScopeVariable.enabled = false;
ProhibitSetNoCompatible.enabled = false;
};
};
};
test.stubs = { vim-vint = { }; };
nmt.script = ''
assertFileContent home-files/.config/.vintrc.yaml ${
./basic-configuration.yaml
}
'';
}